Setup Problems

Problems installing or using the NOP Design Free Shopping Cart that do not fit into one of the above categories.

Moderators: Koibito, Stefko, Randy

Setup Problems

Postby Dan13 » Tue Oct 05, 2010 1:17 pm

Hi,

I need some help please.

Downloaded the files and did the installation. I am not a programmer guy, so just followed the step by step instructions, reproducing everything exactly as listed. Haven't customized anything. Just used the suggested code for the product and managecart and checkout.

The "Add to Cart" button works fine and clicking on the "checkout now" link takes me to the "manage cart" page. Then clicking on the "checkout" button takes me to the "Checkout" page.

Now the checkout page is a bit confusing. It has the form to be filled out and I also added to the page the code for PayPal checkout. Filling out the form and clicking the submit button returns the following error:

The requested URL /cgi-bin/formmail was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


How do I fix that?

Clicking on the Checkout button generated by the PayPal code takes me to the PayPal homepage (the browser address bar showing https://www.paypal.com/cgi-bin/webscr). The cart data is not being transferred to PayPal. Why is that?

Thanks,
Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Dan13 » Wed Oct 06, 2010 9:40 am

Anybody?

Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Tom4us » Wed Oct 06, 2010 4:39 pm

Perhaps whn you post your url here, u can get some help.
Tom4us
Guru
 
Posts: 55
Joined: Fri Feb 07, 2003 11:02 am
Location: Kenya

Re: Setup Problems

Postby Dan13 » Fri Oct 08, 2010 4:22 pm

Hi Tom,

Thanks for the reply. Sorry I didn't reply you sooner - just now did I went to this forum to check it, was assuming I would get notified if someone posts a reply to my post...

Here is the the URL:

http://www.dyengineering.com/Connector.html

Not actually a product. Just trying to get the idea.

Thanks,
Dan


EDIT:

Just found the Subscribe Topic button at the bottom :)
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Stefko » Fri Oct 08, 2010 8:26 pm

try changing what you have now on checkout page for your PayPal info with something more like this:

Code: Select all
<input type="hidden" name="cmd" value="_xclick">
<input type="hidden" name="business" value="EMAIL@MYDOMAIN.COM">
<input type="hidden" name="undefined_quantity" value="0">
<input type="hidden" name="custom" value="COMPANY NAME HERE">
<input type="hidden" name="rm" value="1">
<input type="hidden" name="image_url" value="http://MYDOMAIN.COM/images/MYLOGO.jpg">
<input type="hidden" name="no_shipping" value="0">
<input type="hidden" name="return" value="http://MYDOMAIN.COM/thanks.html">
<input type="hidden" name="cancel_return" value="http://MYDOMAIN.COM/managecart.html/">
KFL Technologies
Web-Enabled Solutions
e-Commerence Solutions
Stefko
Contributor / Guru
 
Posts: 833
Joined: Wed Sep 18, 2002 1:11 am
Location: Wichita, KS

Re: Setup Problems

Postby Dan13 » Sat Oct 09, 2010 6:40 am

Hi,

Thanks for the reply. Please bear with me, I am not a programmer person. What exactly this code is supposed to do? Where to add? Added it (please see the URL) but still having the same trouble. Sorry for sounding silly...

Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Dan13 » Mon Oct 11, 2010 6:09 am

Can anybody help please?

Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Stefko » Mon Oct 11, 2010 1:30 pm

first, you should make this setting in nopcart.js

PaymentProcessor = 'pp';


this should start the ball rolling....
KFL Technologies
Web-Enabled Solutions
e-Commerence Solutions
Stefko
Contributor / Guru
 
Posts: 833
Joined: Wed Sep 18, 2002 1:11 am
Location: Wichita, KS

Re: Setup Problems

Postby Dan13 » Mon Oct 11, 2010 5:07 pm

Hi Stefko,

Thanks for the reply. Just added this setting, but still have the same problems. Namely, there are two problems:

1. Clicking the checkout button on the checkout page, loads the PayPal homapage without transferring the purchase details to it.
2. Clicking the submit button wouldn't send an email notification.

Once I get this resolved I would like to have one button instead of two (checkout and submit) that would both send an email notifications (both to me and the customer) and redirect to PayPal for complete the order. Is this possible?

Thanks,
Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Stefko » Mon Oct 11, 2010 7:21 pm

ok, looking at the source code for checkout page, what a mess....

first just work on sending the data to PayPal only, forget about sending an email for now, one issue to focus on only, and 1 form only !

keep me updated
KFL Technologies
Web-Enabled Solutions
e-Commerence Solutions
Stefko
Contributor / Guru
 
Posts: 833
Joined: Wed Sep 18, 2002 1:11 am
Location: Wichita, KS

Re: Setup Problems

Postby Dan13 » Mon Oct 11, 2010 7:29 pm

Sorry for the mess. Different documents for nopERcart suggest slightly different code snippets and I was trying everything I could find.

I agree with you that I need to deal with one issue at a time and I will start with transferring the data to PayPal as you suggest. But how exactly to do this? Doesn't seem to work for me. Copied the code as appears on a checkout page of a working example, but it doesn't work here. What am I doing wring.

Thanks,
Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Stefko » Mon Oct 11, 2010 7:33 pm

i'll read-up on nopERcart and get back with ya if one else comes forward
KFL Technologies
Web-Enabled Solutions
e-Commerence Solutions
Stefko
Contributor / Guru
 
Posts: 833
Joined: Wed Sep 18, 2002 1:11 am
Location: Wichita, KS

Re: Setup Problems

Postby Dan13 » Mon Oct 11, 2010 7:39 pm

Many thanks for your help!

Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Dan13 » Mon Oct 18, 2010 2:11 pm

Hi Stefko,

Were you able to figure it out?

Dan
Dan13
WebMaster
 
Posts: 16
Joined: Tue Oct 05, 2010 12:56 pm

Re: Setup Problems

Postby Stefko » Mon Oct 18, 2010 8:30 pm

not much time these days, perhaps Koibito can help, I think he knows a bit about NOPERcart
KFL Technologies
Web-Enabled Solutions
e-Commerence Solutions
Stefko
Contributor / Guru
 
Posts: 833
Joined: Wed Sep 18, 2002 1:11 am
Location: Wichita, KS

Next

Return to Help: Cart / General

Who is online

Users browsing this forum: wuhuilin11 and 5 guests